안드로이드 스튜디오 구버전 실행(android studio old version execution)

Posted by sub3
2017.07.04 08:54 개발

구버전으로 모든 기기에 앱이 돌아가도록 만들려고 시도해보던중

시작부터 다음과 같은 에러 메시지에 봉착하게 되었다.



Error:Execution failed for task ':app:processDebugManifest'.

Manifest merger failed : uses-sdk:minSdkVersion 9 cannot be smaller than version 14 declared in library /Users/idemax/Development/Workspaces/NGTProjects/nnotes/APP/v2/app/build/intermediates/exploded-aar/com.ikimuhendis/ldrawer/0.1/AndroidManifest.xml
Suggestion: use tools:overrideLibrary="android.support.design" to force usage



해결방법은 AndroidManifest.xml의 수정으로 해결되었다.


< xml version="1.0" encoding="utf-8">

<manifest
   xmlns:android="http://schemas.android.com/apk/res/android" 
    xmlns:tools="http://schemas.android.com/tools" 
    package="com.example.test">
  
   <uses-sdk  tools:overridelibrary="android.support.*">

<manifestfest>





참고

https://github.com/keklikhasan/LDrawer/issues/14



저작자 표시
신고
Tags
이 댓글을 비밀 댓글로

티스토리 툴바